1007 Maximum Subsequence Sum (25分) Python解法
发布日期:2021-05-08 02:32:51 浏览次数:10 分类:精选文章

本文共 2161 字,大约阅读时间需要 7 分钟。

Given a sequence of K integers { N​1, N​2​​ , …, N​K}. A continuous subsequence is defined to be { N​i, N​i+1, …, N​j} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10

-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

利用动态规划思想dp[i]=max(nums[i],nums[i]+dp[i-1]),同时记录好初始位置p和连续数组长度dis即可,q=p+dis。

a=int(input())nums=input().split()co=0for i in range(a):        nums[i]=int(nums[i])        if nums[i]<0:                co+=1if(co==a):        print(0,nums[0],nums[a-1])else:        n=len(nums)        dp=[0]*n        t=-1000        dis=0        d=0        for i in range(0,n):                if i==0 :                        dp[0]=nums[i]                        p=0                        q=0                else:                        dp[i]=max(nums[i],nums[i]+dp[i-1])                        if(dp[i]==nums[i]):                                d=i                                dis=0                        else:                                dis+=1                if dp[i]>t:                        t=dp[i]                        p=d                        q=dis+d        print(t,nums[p],nums[q])

在这里插入图片描述

上一篇:unity2d实现碰撞后物体随力转动(Hinge Joint 2D理解)
下一篇:Java系统定义的运行异常及其含义

发表评论

最新留言

感谢大佬
[***.8.128.20]2025年04月03日 17时57分00秒