
本文共 2161 字,大约阅读时间需要 7 分钟。
Given a sequence of K integers { N1, N2 , …, NK}. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
利用动态规划思想dp[i]=max(nums[i],nums[i]+dp[i-1]),同时记录好初始位置p和连续数组长度dis即可,q=p+dis。
a=int(input())nums=input().split()co=0for i in range(a): nums[i]=int(nums[i]) if nums[i]<0: co+=1if(co==a): print(0,nums[0],nums[a-1])else: n=len(nums) dp=[0]*n t=-1000 dis=0 d=0 for i in range(0,n): if i==0 : dp[0]=nums[i] p=0 q=0 else: dp[i]=max(nums[i],nums[i]+dp[i-1]) if(dp[i]==nums[i]): d=i dis=0 else: dis+=1 if dp[i]>t: t=dp[i] p=d q=dis+d print(t,nums[p],nums[q])
发表评论
最新留言
关于作者
