实验10-1 圆形体体积计算器 (20 分)
发布日期:2021-06-29 22:19:29 浏览次数:3 分类:技术文章

本文共 1500 字,大约阅读时间需要 5 分钟。

实验10-1 圆形体体积计算器 (20 分)

本题要求实现一个常用圆形体体积的计算器。计算公式如下:

球体体积 V=

​3
​4
​​ πr
​3
​​ ,其中r是球体半径。
圆柱体体积 V=πr
​2
​​ h,其中r是底圆半径,h是高。
圆锥体体积 V=
​3
​1
​​ πr
​2
​​ h,其中r是底圆半径,h是高。
输入格式:
在每次计算之前,要求输出如下界面:

1-Ball

2-Cylinder
3-Cone
other-Exit
Please enter your command:
然后从标准输入读进一个整数指令。

输出格式:

如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。

当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;

当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。
计算结果在一行内输出,保留小数点后两位。

输入样例:

1
2
3
2.4 3
0
输出样例:
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
#include<stdio.h>//输入样例和输出样例只要在同一个显示器上,不管位置在哪里,都是正确的;
#include<math.h>
#define PI atan(1.0)4//也可以是acos(-1.0)=3.141592653589793;
int main()
{
int choice;
double r,h;//半径和高都是实数;
while(1)
{
printf(“1-Ball\n2-Cylinder\n3-Cone\nother-Exit\nPlease enter your command:\n”);
scanf("%d",&choice);
if(choice==1)
{
printf(“Please enter the radius:\n”);
scanf("%lf",&r);
printf("%.2lf\n",4
1.0/3PIrrr);
}
else if(choice= =2)
{
printf(“Please enter the radius and the height:\n”);
scanf("%lf %lf",&r,&h);
printf("%.2lf\n",PIrrh1.0);
}
else if(choice==3)
{
printf(“Please enter the radius and the height:\n”);
scanf("%lf %lf",&r,&h);
printf("%.2lf\n",1.0/3PIrrh*1.0);
}
else break;
}
return 0;
}

转载地址:https://dingshijie.blog.csdn.net/article/details/87260226 如侵犯您的版权,请留言回复原文章的地址,我们会给您删除此文章,给您带来不便请您谅解!

上一篇:实验11-1-1 英文单词排序 (25 分)
下一篇:实验7-2-6 打印杨辉三角 (20 分)

发表评论

最新留言

路过,博主的博客真漂亮。。
[***.116.15.85]2024年05月03日 03时12分27秒